首页 > 网络资讯 > 常见问题 > 其他问题 >
wdcp常见组件安装方法 memcahce,mysql_innodb,升级php5.3等
分享至:0
2016-07-18 22:25:41     来源:互联网     点击:
导读:

北京云主机产业基地 安装以下脚本时,请注意服务器内是否有安装云锁,安装前请先卸载

通过ssh方式登陆服务器后输入以下命令即可下载脚本并执

wget http://www.bjcloud.net/soft/vps/wdcp/memcachednew.sh  自适应wdcp默认php5.2.17或脚本升级后的php5.3.29

sh memcachednew.sh

其他脚本
http://www.bjcloud.net/soft/vps/wdcp/mysql_innodb_ins.sh   mysql innodb引擎支持
http://www.bjcloud.net/soft/vps/wdcp/iconv_ins.sh          php5.3.29已默认编译支持
http://www.bjcloud.net/soft/vps/wdcp/soapnew.sh           自适应wdcp默认php5.2.17或脚本升级后的php5.3.29
http://www.bjcloud.net/soft/vps/wdcp/bcmathnew.sh         自适应wdcp默认php5.2.17或脚本升级后的php5.3.29

http://www.bjcloud.net/soft/vps/wdcp/exif_insnew.sh       自适应wdcp默认php5.2.17或脚本升级后的php5.3.29

http://www.bjcloud.net/soft/vps/wdcp/sockets_ins new.sh   自适应wdcp默认php5.2.17或脚本升级后的php5.3.29

http://www.bjcloud.net/soft/vps/wdcp/PHP_APC.sh           自适应wdcp默认php5.2.17或脚本升级后的php5.3.29

http://www.bjcloud.net/soft/vps/wdcp/mysqli_ins.sh    自适应wdcp默认php5.2.17或脚本升级后的php5.3.29

http://www.bjcloud.net/soft/vps/wdcp/zip.sh


http://www.bjcloud.net/soft/vps/wdcp/pdo_mysql_ins.sh  (php5.2pdo_mysql支持)

http://www.bjcloud.net/soft/vps/wdcp/pdo_mysql_ins5.3.sh  (php5.3pdo_mysql支持)

 

升级mysql5.5.36|5.6.15

适合新开通wdcp环境的vps/云服务器,若有重要数据,请自行备份,升级mysql后需重新编译php,所以推荐升级数据库后
再升级php5.3/5.4或更高版本
wget http://www.bjcloud.net/soft/vps/wdcp/mysql5.6.sh
sh mysq5.6.sh 
若要升级5.6.15则执行 
sh mysql5.6.sh 5.6 

 

升级到php5.3

需要说明升级5.3后,原来服务器上必须使用php 5.2运行的网站将无法正常使用,请知悉,谢谢 

wget http://www.bjcloud.net/soft/vps/wdcp/php_up53.sh
sh php_up53.sh

wget http://www.bjcloud.net/soft/vps/wdcp/pdo_mysql_ins5.3.sh

sh pdo_mysql_ins5.3.sh

wget http://down.wdlinux.cn/in/ZendGL_ins.sh
sh ZendGL_ins.sh
wget http://down.wdlinux.cn/in/eac0961_ins.sh
sh eac0961_ins.sh
shutdown -r now
注意:升级后将不支持Zend Optimizer,将会和以前程序不兼容,需确认程序必须使用5.3方可执行(执行要进行大量编译,一般半小时-1小时才能安装完成)
 

升级到php5.4|5.5|5.6
先升级gmp-devel
rm /etc/yum.repos.d/rpmforge.repo

yum install gmp-devel 

再升级php5.4
wget http://www.bjcloud.net/soft/vps/wdcp/php_up54.sh

sh php_up54.sh
如果需要安装其它版本用这样即可:sh php_up54.sh 版本号;
5.5版本目前最高5.5.32,使用sh php_up54.sh 5.5.32即可

5.6版本目前最高5.6.18,使用sh php_up54.sh 5.6.18即可


升级到php7.0.4

wget http://www.bjcloud.net/soft/vps/wdcp/php_up7.0.4.sh

sh php_up7.0.4.sh 7.0.4

 

安装zend guard,
wget http://www.bjcloud.net/soft/vps/wdcp/Zendguard6.sh
sh Zendguard6.sh 5.4
php5.5.x版本,执行sh Zendguard6.sh 5.5
php5.6.x版本,执行sh Zendguard6.sh 5.6 
重启服务

 

URL地址不区分大小写

wget http://www.bjcloud.net/soft/vps/wdcp/speling.sh

sh speling.sh